Forum

ASSIST, AMERICA'S ARMY COMMUNITY - RELIVE THE GLORY DAYS OF AMERICA'S ARMY 2.5


Author Topic: Cannot join own gameserver on Linuxserver at home  (Read 6068 times)

0 Members and 1 Guest are viewing this topic.

Offline EnerGy_NL

Cannot join own gameserver on Linuxserver at home
« on: Friday, May 03, 2013, 16:32:09 PM »
Helllo everybody,

I have some problems with joining my own gameserver hosted on a linuxserver at my home. When i join it looks like there is somthing going wrong with the authorization. I see ingame my honor as 15 (should be 101), while my friend sees me at 101. When i try to join a team i see the F2 screen, but no weaponclasses to pick. Just an empty screen. The server is then also telling that im still an spectator en i wil join this team as soon as possible. After a few min is get kicked by MD5tool for 5 minutes.

I've tried everything, reinstalled the server 10 times. The problem is with any computer on the same network as the server. My friend has no problems at all and he can play smoothly.

Can someone help me with this?
Some screenshots are at the following links:

http://timvm.nl/AA2.5%20server%20EnerGy%201.png
http://timvm.nl/AA2.5%20server%20EnerGy%202.png
http://timvm.nl/AA2.5%20server%20EnerGy%203.png

Thnx!!!!

Greetz EnerGy_NL
« Last Edit: Friday, May 03, 2013, 17:22:28 PM by EnerGy_NL »

Offline [SWISS]Merlin

Re: Cannot join own gameserver on Linuxserver at home
« Reply #1 on: Saturday, May 04, 2013, 10:23:07 AM »
as i can remenber from 2.8.5, i guess you have to do something with the routing. it looks like you are not connecting to the auth server, which means, that you are local at all.
check the ports to be open at your router (NAT). and someting while starting your server (server.ini, i don't remember and no time to search for, sorry). like multihome server or so..
good luck

Offline EnerGy_NL

Re: Cannot join own gameserver on Linuxserver at home
« Reply #2 on: Saturday, May 04, 2013, 13:09:28 PM »
Thnx Merlin,

I have open the following ports:

TCP&UDP:
1716,1717,1718

TCP:
20046,20047,27900

Are there other ports to open?

thnx

Offline [SWISS]Merlin

Re: Cannot join own gameserver on Linuxserver at home
« Reply #3 on: Saturday, May 04, 2013, 19:09:32 PM »
no, I guess this looks good.
but you are in a local network - so it looks like.
you do not connect the auth server at all. I will search for the solution tomorrow.

Offline OICURMT2!

Re: Cannot join own gameserver on Linuxserver at home
« Reply #4 on: Sunday, May 05, 2013, 03:57:58 AM »
Use my iptables on the server... should work.

Also, you will need to bind your server to the external (outbound) interface.  You can set this up using the multihome parameter in the aa25.ini file.

Code: [Select]
*filter
:FORWARD DROP [0:0]
:INPUT DROP [0:0]
:OUTPUT ACCEPT [0:0]
-A INPUT -p udp -m udp --dport 1716:1718 -j ACCEPT
-A INPUT -p udp -m udp --dport 20046:20047 -j ACCEPT
-A INPUT -p udp -m udp --dport 27900 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 443 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 143 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 113 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 110 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 80 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 53 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 25 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 20:22 -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT
COMMIT
# Generated by webmin
*mangle
:FORWARD ACCEPT [0:0]
:INPUT ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
:PREROUTING ACCEPT [0:0]
:POSTROUTING ACCEPT [0:0]
COMMIT
# Completed
# Generated by webmin
*nat
:OUTPUT ACCEPT [0:0]
:PREROUTING ACCEPT [0:0]
:POSTROUTING ACCEPT [0:0]
COMMIT
# Completed

« Last Edit: Sunday, May 05, 2013, 04:00:45 AM by OICURMT2! »
--
Oh, I See You Are Empty Too !

Offline [SWISS]Merlin

Re: Cannot join own gameserver on Linuxserver at home
« Reply #5 on: Sunday, May 05, 2013, 11:04:52 AM »
just an other try:
what is your servername - and tell me the ip-address
whats your router model/name
whats your local ip-address of your computer, not running the server
whats your local ip-address of your computer, where you run the server  (dosbox, -> ipconfig /all)


Offline EnerGy_NL

Re: Cannot join own gameserver on Linuxserver at home
« Reply #6 on: Sunday, May 05, 2013, 18:01:25 PM »
servername: =]Ao2[= Army of 2 || Normal Weapons - Server 2
ip-address:   84.84.41.186
modem/router: KPN experia box
router software: Arcadyan VGV7519, Firmware Version:02.00.124
local ip-address of my computer, not running the server: 192.168.2.11
local ip-address of my computer, where you run the server: 192.168.2.16

@OICURMT2!
So in the ini file the line for multihome should be like this?
multihome=192.168.2.16

how to use those tables? i portforwarded the named ports manually.

----

below some serverconsole log when joining the server:
Quote
UDP recvfrom error: 113 from 192.155.198.210:1716

Client netspeed is 10000
Checking Ban Policy for: Name==]Ao2[=EnerGy_NL; IP=84.84.41.186; MAC=00:25:22:c1:c6:72

New Player Recruit id=22e43ba8cf596238f8f2726b4cbe5a4d
25AssistSM: New Connection (slot #1) 84.84.41.186:65005 [?] "Recruit" (seq 8313800)

[AA25] Player =]Ao2[=EnerGy_NL Authorized, Honor:101

AuthOK 84.84.41.186
25AssistSM: No Master Query Sent - DNS has not yet resolved for AAO1.EVENBALANCE.COM

AuthOK 84.84.41.186

my modem/router log says at the same time:
Quote
05/06/2013  00:19:33 **UDP Flood to Host** 192.168.2.11, 65005->> 84.84.41.186, 1716 (from PPPoE1 Outbound)
« Last Edit: Sunday, May 05, 2013, 18:22:09 PM by EnerGy_NL »

Offline [SWISS]Merlin

Re: Cannot join own gameserver on Linuxserver at home
« Reply #7 on: Monday, May 06, 2013, 06:51:55 AM »
i dont know a lot about multihome, but this looks realy like something with that or port forwarding.
before i search the hell out of it, maybe someone else can help you with that.

for sure  jonnyM could..or some others.
let's see, maybe someone is answering


what i did with my installation also in a LAN and with Servers:
- router NAT entries for UDP 1716-1718 (and all the other needed) for the WAN Port of the router, with port forwarding to the ip of the local server
that's all i did. all other computer in the local network (192.168.1.xx) can join the game correct. i will post you what i have selected over assist, server tab. there is, on top, an entry (dont remember cause at work now) with something to change in this direction you have trouble. i will check this later.
« Last Edit: Monday, May 06, 2013, 08:48:53 AM by [SWISS]Merlin »

Offline EnerGy_NL

Re: Cannot join own gameserver on Linuxserver at home
« Reply #8 on: Sunday, May 26, 2013, 10:40:06 AM »
I have add the ip tables to the server, but no difference at all.
Still seeing myself as honor 15 and also not able to join a team like i said before..
Is there someone who can help me with this via Teamviewer or something?

thnx

Offline Possessed

  • bWpnRecoil == False;
  • Administrator
  • Epic Poster
  • *
  • Posts: 3,579
  • You suffer, but why?!
    • View Profile
  • AA: Possessed
Re: Cannot join own gameserver on Linuxserver at home
« Reply #9 on: Sunday, May 26, 2013, 15:43:48 PM »
I never found a way to ping my own server, I tried Port triggering / Mapping, DMZ and turned Firewall off, nothing worked.
These things I have spoken unto you, that in me ye might have peace. In the world ye shall have tribulation: but be of good cheer; I have overcome the world.
John 16:33


Offline EnerGy_NL

Re: Cannot join own gameserver on Linuxserver at home
« Reply #10 on: Friday, May 31, 2013, 13:42:31 PM »
so its not possible?

Offline OICURMT2!

Re: Cannot join own gameserver on Linuxserver at home
« Reply #11 on: Friday, May 31, 2013, 21:17:29 PM »
@OICURMT2!
So in the ini file the line for multihome should be like this?
multihome=192.168.2.16

how to use those tables? i portforwarded the named ports manually.

Set the multihome back to the default 0.0.0.0 value, it's not needed unless you are directing the server to a specific interface on your box.  For example, my server has 3 NICs, so I tell the server to listen on the IP that is on the outbound card.  I assume your box only has one NIC, so multihome can be defaulted.

As for how to use the tables... let's try one thing at a time...

If you are using a GUI, then you should have some sort of Firewall configuration program.  Turn OFF the firewall on your Linux box (to start with) and make sure your router is forwarding ports correctly.

If that doesn't work, then your problem is on the router.  If it does work, then the problem is on the box.


Let me know what happens, we can take it from there.

BTW: This thread has a link to a Linux setup guide... it may (or may not) help.



I never found a way to ping my own server, I tried Port triggering / Mapping, DMZ and turned Firewall off, nothing worked.

You can't, but you can redirect something like "finger" services and use that to see if your machine is online or not.
--
Oh, I See You Are Empty Too !

Offline kMx

Re: Cannot join own gameserver on Linuxserver at home
« Reply #12 on: Saturday, June 01, 2013, 06:46:51 AM »
Quote



You can't, but you can redirect something like "finger" services and use that to see if your machine is online or not.

not true at all , i can ping my server as i can join it from the server list dont need to click join in the server tab

Offline Possessed

  • bWpnRecoil == False;
  • Administrator
  • Epic Poster
  • *
  • Posts: 3,579
  • You suffer, but why?!
    • View Profile
  • AA: Possessed
Re: Cannot join own gameserver on Linuxserver at home
« Reply #13 on: Saturday, June 01, 2013, 06:59:59 AM »
not true at all , i can ping my server as i can join it from the server list dont need to click join in the server tab
when I had 3G internet I could join by the server list.
maybe this is different if using Bridge mode idk.
These things I have spoken unto you, that in me ye might have peace. In the world ye shall have tribulation: but be of good cheer; I have overcome the world.
John 16:33


Offline OICURMT2!

Re: Cannot join own gameserver on Linuxserver at home
« Reply #14 on: Saturday, June 01, 2013, 10:38:51 AM »
not true at all , i can ping my server as i can join it from the server list dont need to click join in the server tab

You'll have to explain to me how ICMP traffic can be redirected to an internal IP address from an outside interface.  RFC5508 explicitly allows a return when originating from an internal IP to an external (via NAT), but you cannot ping an internal address from the outside.  The only possible exception I can see is in ICMP-EXT, under section 4.1.  ICMP Error Payload Validation.

I'm not a guru on how NAT traverses accross a gateway device, but I don't see how you can ping, say, 192.168.1.1 from the outside world, as the 192.168.X.X IP addresses are reserve for internal (private) networks.

OIC!
--
Oh, I See You Are Empty Too !

 

Download Assist

×

Download Game Client

Important: Battletracker no longer exists. However, old Battletracker accounts may still work. You can create a new 25Assist account here

Download Server Manager