Forum

ASSIST, AMERICA'S ARMY COMMUNITY


Author Topic: 25Assist Client not run under Ubuntu Linux 15.10  (Read 1552 times)

0 Members and 1 Guest are viewing this topic.

Offline [BAD].Sgt_KCT

25Assist Client not run under Ubuntu Linux 15.10
« on: Monday, October 26, 2015, 16:22:46 PM »
I was run 25Assist client fine under Ubuntu Desktop 14.04.3 LTS, but I upgrade to a new instalation of Ubuntu 15.10 with Unity 7 desktop environment. I download the 25Assist client, unzip on /home/myusername/25Assist folder and tryed execute the app 25Assist.

The bash show an error message: "File or directory not found: 25Assist".

The permission is ok, rwxrwxrwx, I'm the own of folder and files, the mime-type is "application/x-executable".

All other application run fine on Linux. Any idea?

Offline teddy_grizzly_bear

  • Used to be known as nobody
  • Administrator
  • Epic Poster
  • *
  • Posts: 5,260
  • what are you looking at?
    • View Profile
  • AA: teddy_grizzIy_bear
Re: 25Assist Client not run under Ubuntu Linux 15.10
« Reply #1 on: Monday, October 26, 2015, 16:53:33 PM »
I had a bunch of trouble when I ran assist on ubuntu 14.04 myself, most of it was due to needing 32bit libraries.

Which is what is suggested here as well:
http://askubuntu.com/questions/133389/no-such-file-or-directory-but-the-file-exists
Quote
You're probably trying to run a 32-bit binary on a 64-bit system that doesn't have 32-bit support installed.

What I did was run the application from terminal (as SU) and then dealt with each error separately.
Like I said, it was mostly about installing the 32bit libraries (if your system is 64bit it will automatically install those for obvious reasons).
The key is to do
Code: [Select]
apt-get install program:i386(the key being :i386).


"Mathematics may be defined as the subject in which we never know what we are talking about, nor whether what we are saying is true." Bertrand Russell

Offline ELiZ


Offline teddy_grizzly_bear

  • Used to be known as nobody
  • Administrator
  • Epic Poster
  • *
  • Posts: 5,260
  • what are you looking at?
    • View Profile
  • AA: teddy_grizzIy_bear


"Mathematics may be defined as the subject in which we never know what we are talking about, nor whether what we are saying is true." Bertrand Russell

Offline [BAD].Sgt_KCT

Re: 25Assist Client not run under Ubuntu Linux 15.10
« Reply #4 on: Monday, October 26, 2015, 19:53:16 PM »
Thanks, my system is 64 bit and you remember me what 32 bit libraries of architecture i386 was need to install:

Code: [Select]
sudo apt-get install \
    libgtk2.0-0:i386 \
    libc6:i386 \
    libncurses5:i386 \
    libstdc++6:i386 \
    libgl1-mesa-glx:i386 \
    libgl1-mesa-dri:i386

During the execution, a warning message require the following meta packages gnome-session-canberra:i386 and gtk2-engines-murrine:i386, but this modules breaks the dependence of same packages in amd64 architecture and all Unity desktop environment, then I can't install them more.

However, now is required run 25Assist as root with sudo.

Code: [Select]
sudo /home/myusername/25Assist/25Assist
This is a huge breech of security. There is a form of run it as usual user?

Offline [BAD].Sgt_KCT

Re: 25Assist Client not run under Ubuntu Linux 15.10
« Reply #5 on: Monday, October 26, 2015, 21:41:34 PM »
Thank you, Teddy and ELiZ for attention!

The 25Assist just is running nice with an usual user. Left only the audio that is muted.

Kind regards.

Offline Pipez0r

Re: 25Assist Client not run under Ubuntu Linux 15.10
« Reply #6 on: Tuesday, October 27, 2015, 04:00:04 AM »
I had all those problems with ubuntu 14.04. I recommend to install all those 32-bit libs that it asks for, at least for me it didnt cause any problems, I think didnt cause any dependency problems either.

In Linux Mint those libs were already present, so game worked without doing anything. Anyway I reinstalled Ubuntu, because Mint had some other problems with its gui.

Do you like Unity? I personally couldnt have Linux with it, its so weird somehow and also heavier than nicer desktops. I prefer Mate, which is similar to gnome2.

Now Im a Windblows user again anyway ^^

 

Download Assist

×

Download Game Client


Download Server Manager