Forum

ASSIST, AMERICA'S ARMY COMMUNITY


Author Topic: How to install on Arch Linux  (Read 27691 times)

0 Members and 1 Guest are viewing this topic.

Offline hiroru

  • Jr. Member
  • **
  • Posts: 1
    • View Profile
  • AA: hiroru
How to install on Arch Linux
« on: Sunday, February 14, 2016, 04:16:27 AM »
Hi everybody,

This aims to be an small how to install aao25 client into Arch Linux 64bits computer. So, let's get to work!

Enable multilib repository:
Uncomment this line from your /etc/pacman.conf file.
Code: [Select]
[multilib]
Include = /etc/pacman.d/mirrorlist

Install necessary libs:
Code: [Select]
pacman -S lib32-glib2 lib32-gtk2
That's all! Now you can run aao25 installer from everywhere you'd downloaded!

Have a nice play!
« Last Edit: Sunday, February 14, 2016, 04:18:33 AM by hiroru »

Offline Ganja

Re: How to install on Arch Linux
« Reply #1 on: Sunday, February 14, 2016, 06:00:56 AM »
Cool initiative !

Offline Pipez0r

Re: How to install on Arch Linux
« Reply #2 on: Sunday, February 14, 2016, 06:59:20 AM »
With Ubuntu and Mint its pretty much same. Its important to install 32-bit libraries to get assist and aa to work. Ubuntu seems to be better than Mint in many things but for me it seemed with assist that Ubuntu lacks all those libs and Mint doesnt.

Anyhow if someone experiences problems in starting up assist or aa, or ingame sounds are not working, I recomment trying to run the problematic executable in terminal to see the error messages. Then installing needed libs such as ia32 and gtk2 libs.

If the assist executable doesnt start up at all, I recommend going to assist folder in terminal and  typing: chmod +x assistexecutablename

Assist folder is normally in /home/yourusername/desktop and you can navigate there in terminal with "cd" command and listing the folder with "ls"

In both, Ubuntu and Mint, installation command is: sudo apt-get install

After the command the file exact name (if you are not sure, google for it or try the beginning of filename and it will maybe recommend you something.)

Maybe you need to add a repository for those libs before installing them, through google you find how and what to do with Mint and Ubuntu (Mint is based on Ubuntu and Ubuntu on Debian if I remember correctly.)


Offline Koden

  • Cogito Ergo Khodohn
  • Global Moderator
  • Epic Poster
  • *
  • Posts: 2,308
  • Hmmm rainbows.
    • View Profile
Re: How to install on Arch Linux
« Reply #3 on: Sunday, February 14, 2016, 07:21:41 AM »
Thanks for the info. /sticked

Offline Wicos

  • Jr. Member
  • **
  • Posts: 1
    • View Profile
  • AA: Wicos
Re: How to install on Arch Linux
« Reply #4 on: Wednesday, November 23, 2016, 12:04:25 PM »
Hi everybody,

This aims to be an small how to install aao25 client into Arch Linux 64bits computer. So, let's get to work!

Enable multilib repository:
Uncomment this line from your /etc/pacman.conf file.
Code: [Select]
[multilib]
Include = /etc/pacman.d/mirrorlist

Install necessary libs:
Code: [Select]
pacman -S lib32-glib2 lib32-gtk2
That's all! Now you can run aao25 installer from everywhere you'd downloaded!

Have a nice play!
---------------------------------------------------
Estou com o seguinte problema ao tentar a instalação no Arch Linux:
[[email protected]]: ~/Downloads/25Assist-Linux>$ sudo ./25Assist

(25Assist:1384): Gtk-WARNING **: Não foi possível localizar a ferramenta de temas no module_path: "adwaita",

(25Assist:1384): Gtk-WARNING **: Não foi possível localizar a ferramenta de temas no module_path: "adwaita",
Falha de segmentação

-----------------------------------------------------
Saberia informar a solução? Obrigado.

Offline Possessed

  • bWpnRecoil == False;
  • Administrator
  • Epic Poster
  • *
  • Posts: 3,363
  • You suffer, but why?!
    • View Profile
    • nsfw
  • AA: Possessed
Re: How to install on Arch Linux
« Reply #5 on: Wednesday, November 23, 2016, 13:13:05 PM »
---------------------------------------------------
Estou com o seguinte problema ao tentar a instalação no Arch Linux:
[[email protected]]: ~/Downloads/25Assist-Linux>$ sudo ./25Assist

(25Assist:1384): Gtk-WARNING **: Não foi possível localizar a ferramenta de temas no module_path: "adwaita",

(25Assist:1384): Gtk-WARNING **: Não foi possível localizar a ferramenta de temas no module_path: "adwaita",
Falha de segmentação

-----------------------------------------------------
Saberia informar a solução? Obrigado.
Tente isso:
sudo apt install gnome-themes-standard

Eu não sei se o comando vai funcionar no Arch Linux, mas aqui tem mais info do pacote pro arch:
https://aur.archlinux.org/packages/lib32-gnome-themes-standard/
« Last Edit: Wednesday, November 23, 2016, 13:21:19 PM by Possessed »
These things I have spoken unto you, that in me ye might have peace. In the world ye shall have tribulation: but be of good cheer; I have overcome the world.
John 16:33


 

Download Assist

×

Download Game Client


Download Server Manager